

<!DOCTYPE html>

<html lang="en" xmlns:og="http://opengraphprotocol.org/schema/">

<head> 

  

  <meta charset="utf-8">

  <meta name="viewport" content="width=device-width, initial-scale=1">

  <meta http-equiv="Content-Type" content="text/html">

  <title>NFL Roundup: Aaron Rodgers continues to haunt Cowboys in 34-24 win | The Daily Courier | Prescott, AZ</title>

  

  
  

  
    
      
        <meta class="paywall-meta" name="__sync_contentCategory" content='Paid' />
        <meta name='__sync_tenantId' content='wn_pni'>
      
    
  
    
  



  

  <meta property="fb:app_id" content="348030695626645" />

  <meta property="og:title" content="NFL Roundup: Aaron Rodgers continues to haunt Cowboys in 34-24 win">

  <meta property="og:type" content="article">

  <meta property="og:url" content="https://www.dcourier.com/news/2019/oct/06/nfl-roundup-aaron-rodgers-continues-haunt-cowboys-/">

  

  <meta property="og:image" content="https://westernnews.media.clients.ellingtoncms.com/img/photos/2019/10/06/nfl_roundup_AP_1.jpg" />

  

  <meta property="og:description" content="Aaron Rodgers looked quite comfortable at the home of the Dallas Cowboys — again. Green Bay&#39;s star quarterback kept his team moving to a big early lead with more dazzling plays at AT&amp;T Stadium, Aaron Jones scored a career-high four touchdowns and the Packers bounced back from their first loss by hanging on.">

  <meta property="og:site_name" content="The Daily Courier">

  <meta name="twitter:title" content="NFL Roundup: Aaron Rodgers continues to haunt Cowboys in 34-24 win">

  

  <meta name="twitter:card" content="summary_large_image">

  <meta name="twitter:site" content="@www.dcourier.com">

  <meta name="twitter:image" content="https://westernnews.media.clients.ellingtoncms.com/img/photos/2019/10/06/nfl_roundup_AP_1.jpg">

  

  

  <meta name="twitter:description" content="">

  

  <meta name="twitter:widgets:csp" content="on">



  

  



  <link rel="stylesheet" href="https://westernnews.media.clients.ellingtoncms.com/static-3/custom/print.css?v=18" type="text/css" media="print">

  <link  href="https://westernnews.media.clients.ellingtoncms.com/static-3/vendors/datepicker/datepicker.min.css" rel="stylesheet">



  <!--[if IE 6]><link rel="stylesheet" href="https://westernnews.media.clients.ellingtoncms.com/static-3/ellington_defaults/2.3.0/stylesheets/ie6.css" type="text/css" media="screen"><![endif]-->

  <!--[if IE 7]><link rel="stylesheet" href="https://westernnews.media.clients.ellingtoncms.com/static-3/ellington_defaults/2.3.0/stylesheets/ie7.css" type="text/css" media="screen"><![endif]-->



<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/semantic-ui/2.4.1/semantic.min.css">

<link rel="stylesheet" href="https://westernnews.media.clients.ellingtoncms.com/static-3/custom/dist/css/main.min.css?v=294" type="text/css">





<script

  src="https://code.jquery.com/jquery-3.3.1.min.js"

  integrity="sha256-FgpCb/KJQlLNfOu91ta32o/NMZxltwRo8QtmkMRdAu8="

  crossorigin="anonymous"></script>



  

  <link rel="icon" type="image/x-icon" href="https://westernnews.media.clients.ellingtoncms.com/static-3/custom/dcourier/logos/favicon.ico" sizes="32x32">

  <link rel="icon" type="image/png" href="https://westernnews.media.clients.ellingtoncms.com/static-3/custom/dcourier/logos/favicon.png" sizes="32x32">



  <script type="text/javascript">

    var STATIC_MEDIA_URL = 'https://westernnews.media.clients.ellingtoncms.com/static-3/';

  </script>

  

  <script src="https://polyfill.io/v2/polyfill.min.js?features=IntersectionObserver"></script>

  <script type="text/javascript" src="https://westernnews.media.clients.ellingtoncms.com/static-3/javascript/lozad.min.js"></script>

  <script src="https://cdnjs.cloudflare.com/ajax/libs/semantic-ui/2.4.1/semantic.min.js"></script>

  <script type="text/javascript" src="https://westernnews.media.clients.ellingtoncms.com/static-3/ellington_defaults/2.3.0/javascript/lib/cookies.js"></script>

  <script type="text/javascript" src="https://westernnews.media.clients.ellingtoncms.com/static-3/javascript/js-cookie.js"></script>

  <script type="text/javascript" src="https://maps.googleapis.com/maps/api/js?key=AIzaSyAPfAD5-v4cObqJcVA7x5izMVPKJ-Q-qds" ></script>





  

<script>

  var syncPaymeter = {

    onLoad: function(meter){

      meter.events.registerHandler(meter.events.onAuthorizeSuccess,

        function(ctx){

          document.getElementById('flipp-overlay').style.display = 'none';

          document.getElementById('circularhub_module_2880').style.display = 'block';

          // console.log('++++++++++++++++++++++ Authorization Success ' + ctx.statusMsg); 

        });

      meter.events.registerHandler(meter.events.onWallFired,

        function(ctx){

          // console.log('++++++++++++++++++++++ Wall Fired ' + ctx.statusMsg);

        });

      meter.events.registerHandler(meter.events.onSessionStarting,

        function(ctx){

          // console.log('++++++++++++++++++++++ Session Starting');

        });

      meter.events.registerHandler(meter.events.onSessionStarted,

        function(ctx){

          // console.log('++++++++++++++++++++++ Session Started');

        });

      meter.events.registerHandler(meter.events.onSessionSaving,

        function(ctx){

          // console.log('++++++++++++++++++++++ Session Saving');

        });

      meter.events.registerHandler(meter.events.onSessionSaved,

        function(ctx){

          // console.log('++++++++++++++++++++++ Session Saved ' + ctx.statusMsg);

        });

      meter.events.registerHandler(meter.events.onAuthorizeStarting,

        function(ctx){

          // console.log('++++++++++++++++++++++ Authorization Starting');

        });

      meter.events.registerHandler(meter.events.onAuthorizeFailed,

        function(ctx){

          // console.log('++++++++++++++++++++++ Authorization FAILED ' + ctx.statusMsg);

        });

      meter.events.registerHandler(meter.events.onServerError,

        function(ctx){

          // console.log('++++++++++++++++++++++ SERVER ERROR ' + ctx.statusMsg);

        });

    }

  };

</script>

<script type="text/javascript" src="https://subscribe.dcourier.com/wn/pni/api/scripts/syncwall"></script>



  <script src="https://westernnews.media.clients.ellingtoncms.com/static-3/vendors/datepicker/datepicker.min.js"></script>

  <script src="https://westernnews.media.clients.ellingtoncms.com/static-3/vendors/momentjs/moment.min.js"></script>

  

  <link type="application/rss+xml" rel="alternate" href="/rss/headlines/">

  

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>

<script>

  var googletag = googletag || {};

  googletag.cmd = googletag.cmd || [];

</script>

  

<script>

  googletag.cmd.push(function() {

    var desktopMapping = googletag.sizeMapping().

      addSize([768, 0], [[989, 150], [728,90], [300, 600], [300, 250]]).

      addSize([0, 0], []).

      build();

    var mobileMapping = googletag.sizeMapping().

      addSize([768, 0], []).

      addSize([0, 0], [[320, 50], [300, 250], [310, 310]]).

      build();

    googletag.defineSlot('/66820660/dc_rr_1', [[300, 250], [300, 600]], 'div-gpt-ad-1549645330807-0').defineSizeMapping(desktopMapping).addService(googletag.pubads());

    googletag.defineSlot('/66820660/dc_rr_2', [[300, 600], [300, 250]], 'div-gpt-ad-1549646914054-0').defineSizeMapping(desktopMapping).addService(googletag.pubads());

    googletag.defineSlot('/66820660/dc_rr_3', [[300, 250], [300, 600]], 'div-gpt-ad-1549647070425-0').defineSizeMapping(desktopMapping).addService(googletag.pubads());

    googletag.defineSlot('/66820660/yavapai_medical_sponsor', [989, 150], 'div-gpt-ad-1531784242824-0').defineSizeMapping(desktopMapping).addService(googletag.pubads());

    googletag.defineSlot('/66820660/dc_hp_lb_1', [[728, 90], [989, 150]], 'div-gpt-ad-1550011497814-0').defineSizeMapping(desktopMapping).addService(googletag.pubads()).setCollapseEmptyDiv(true);
    
    googletag.defineSlot('/66820660/hp_lb_2', [[728, 90], [989, 150]], 'div-gpt-ad-1558021403667-0').addService(googletag.pubads());

    googletag.defineSlot('/66820660/dc_leaderboard_1', [[728, 90], [989, 150]], 'div-gpt-ad-1550159693568-0').defineSizeMapping(desktopMapping).addService(googletag.pubads());
    
    googletag.defineSlot('/66820660/dc_footer_lb', [[989, 150], [728, 90]], 'div-gpt-ad-1549647228842-0').defineSizeMapping(desktopMapping).addService(googletag.pubads());

    googletag.defineSlot('/66820660/special_promo', [[989, 150], [728, 90]], 'div-gpt-ad-1568308788718-0').defineSizeMapping(desktopMapping).addService(googletag.pubads());

    googletag.defineSlot('/66820660/special_promo_mb', [[320, 50], [300, 250]], 'div-gpt-ad-1568309055513-0').defineSizeMapping(mobileMapping).addService(googletag.pubads());

    googletag.defineSlot('/66820660/dc_mobile_footer', [[320, 50], [300, 250]], 'div-gpt-ad-1550166102071-0').defineSizeMapping(mobileMapping).addService(googletag.pubads());

    googletag.defineSlot('/66820660/dc_hp_medrec_1', [300, 250], 'div-gpt-ad-1549649929836-0').addService(googletag.pubads());

    googletag.defineSlot('/66820660/dc_hp_medrec_2', [300, 250], 'div-gpt-ad-1549650025774-0').addService(googletag.pubads());

    googletag.defineSlot('/66820660/dc_mb_footer', [310, 310], 'div-gpt-ad-1549650210581-0').defineSizeMapping(mobileMapping).addService(googletag.pubads()); //yeildmo

    googletag.defineSlot('/66820660/dc_mb_ict_new', [[300, 250], [320, 50]], 'div-gpt-ad-1549650435114-0').defineSizeMapping(mobileMapping).addService(googletag.pubads());

    googletag.defineSlot('/66820660/search_sponsor', [320, 50], 'div-gpt-ad-1549928193438-0').defineSizeMapping(mobileMapping).addService(googletag.pubads());

    googletag.pubads().collapseEmptyDivs(true);

    googletag.enableServices();

  });

</script>



  

  

  

</head>

<body class="news story_detail revision" id="story_848902">

  <div class="ui top sidebar vertical menu top-more-menu">

    

  <div class="ui centered aligned page grid">

  <div class="one column row">

    <div class="sixteen wide column"></div>

  </div>

  <div class="five column row">

    <div class="column">

      <div class="item">

        <div class="header">OFFERS</div>

      </div>

      <a class="item top-more-menu-item" href="https://www.retailmenot.com/everyday">RetailMeNot Everyday</a>

      <a class="item top-more-menu-item" target="_blank" href="http://www.smartsource.com">Smart Source Coupons</a>

      <a class="item top-more-menu-item" target="_blank" href="http://www.circularhub.com/?p=pni#!/flyers/target-circular?flyer_run_id=46644">This Week's Circulars (Flipp)</a>

      <a class="item top-more-menu-item" target="_blank" href="http://www.928medialab.com">928 Media Lab</a>

      <a class="item top-more-menu-item" href="/purchase-photo/">Purchase a Photo</a>

    </div>

    <div class="column">

      <div class="item">

        <div class="header">SUBMISSIONS</div>

      </div>

      <a class="item top-more-menu-item" href="/submit/">General Submissions</a>

      <a class="item top-more-menu-item" href="/letter-tips/">Letter Submission Tips</a>

      <a class="item top-more-menu-item" href="/faith-values/">Submit Faith &amp; Values Notice</a>

      <a class="item top-more-menu-item" href="https://classifiedsplacement.westernnews.com/dcourierui814/WFCategoryClassification.aspx" target="_blank">Place an Ad</a>

      <a class="item top-more-menu-item" href="/subscriber-services/stop-start/">Subscriber Services (Start / Stop)</a>
      
      <a class="item top-more-menu-item" href="/submit/obituary/">Obituary Submission Guidelines</a>

      <a href="/submit-event/" class="item top-more-menu-item">Submit Event</a>

    </div>

    <div class="column">

      <div class="item">

        <div class="header">MEDIA</div>

      </div>

      <a class="item top-more-menu-item" href="/pre-website-archives/">Archives: Pre-Web</a>

      <a class="item top-more-menu-item" href="/users/newsletters-dc/">Newsletter</a>

      <a class="item top-more-menu-item" href="/other-publications/">Other Publications</a>

      <a class="item top-more-menu-item" href="/photos/galleries/">Photo Galleries</a>

      <a class="item top-more-menu-item" href="/news/special-sections/">Special Sections</a>

      <a class="item top-more-menu-item" href="/courier-cooks/">Courier Cooks</a>

    </div>

    <div class="column">

      <div class="item">

        <div class="header">COMMUNITY</div>

      </div>
      <a class="item top-more-menu-item" href="/about/">About Us</a>

      <a class="item top-more-menu-item" href="/classes/">Classes for the Taking</a>

      <a class="item top-more-menu-item" href="/clubs/">Clubs &amp; Meetings</a>

      <a class="item top-more-menu-item" href="/events/2019/oct/">Event Calendar</a>

      <a class="item top-more-menu-item" href="/notices/">Notices</a>

      <a class="item top-more-menu-item" href="/classifieds/category/legals/">Public Notices</a>

      <a class="item top-more-menu-item" href="/volunteer/">Volunteer Opportunities</a>

      <a class="item top-more-menu-item" href="/places/churches/all/">Worship Directory</a>

    </div>

    <div class="column">

      <a href="/e-edition/" class="item"><div class="ui positive button">e-Edition</div></a>

      <a class="item" href="/tv-listings/"><div class="ui primary button">TV Listings</div></a>

      <div class="ui form">

        <form action="/search/" method="get" class="ui icon input"  autocomplete="off" _lpchecked="1">

          <input type="text" name="q" placeholder="Search..." value="">

          <i class="search icon"></i>

        </form>

      </div>
      
    </div>

  </div>

  <div class="one column row">

    <div class="sixteen wide column"></div>

  </div>

</div>



  </div>

  <div class="ui left vertical inverted menu sidebar sidebar-nav">

    

  <div class="item">

  <a href="/news/news/" class="header">NEWS</a>

  <div class="menu">

    <a class="item" href="/news/business/">Business</a>

    <a class="item" href="/news/elections/">Elections</a>

    <a href="/news/hap/" class="item">Happenings &amp; Events</a>

    <a class="item" href="/news/national-international/">National &amp; International</a>

    <a class="item" href="/news/oddnews/">Odd &amp; Interesting</a>

    <a class="item" href="/news/chino-valley-review/">CVRnews.com</a>

    <a class="item" href="/news/prescott-valley-tribune/">PVTrib.com</a>

  </div>

</div>

<div class="item">

  <a href="/news/opinion/" class="header">OPINION</a>

  <div class="menu">

    <a class="item" href="/news/opinion/editorials/">Editorials</a>

    <a class="item" href="/news/opinion/letters/">Letters</a>

    <a class="item" href="/news/opinion/columns/">Columns</a>

    <a class="item" href="/news/opinion/blogs/">Blogs</a>

  </div>

</div>

<div class="item">

  <a href="/news/sports/" class="header">SPORTS</a>

  <div class="menu">

    <a class="item" href="/news/sports/pro/">Pro</a>

    <a class="item" href="/news/sports/preps/">Preps</a>

    <a class="item" href="/news/sports/college/">College</a>

    <a class="item" href="/news/sports/commentary/">Commentary</a>

  </div>

</div>

<div class="item">

  <a href="/news/kudos/" class="header">KUDOS</a>

  <div class="menu">

    <a class="item" href="/news/kudos/out-and-about/">Out &amp; About</a>

    <a class="item" href="/news/kudos/chew-on-this/">Chew On This</a>

    <a class="item" href="/news/kudos/music-and-nightlife/">Music &amp; Nightlife</a>

    <a class="item" href="/kudos-calendar/">Nightlife Calendar</a>

    <a class="item" href="/news/kudos/words/">Words</a>

    <a class="item" href="/news/kudos/stage-and-screen/">Stage &amp; Screen</a>

    <a class="item" href="/news/kudos/art-and-style/">Art &amp; Style</a>

  </div>

</div>

<div class="item">

  <a href="/news/features/" class="header">FEATURES</a>

  <div class="menu">

    <a class="item" href="/courier-cooks/">Courier Cooks</a>

    <a class="item" href="/news/features/neighbors/">Neighbors</a>

    <a class="item" href="/news/features/real-estate/">Real Estate</a>

  </div>

</div>

<div class="item">

  <a href="/news/life/" class="header">LIFE</a>

  <div class="menu">

    <a class="item" href="/news/life/couples/">Couples</a>

    <a class="item" href="/news/life/births/">Birth</a>

    <a class="item" href="/news/life/recognition/">Recognition</a>

  </div>

</div>

<div class="item">

  <a href="/news/oddnews/" class="header">ODD</a>

</div>

<div class="item">

  <a href="/news/obituaries/" class="header">OBITUARIES</a>

</div>

<div class="item">

  <a href="/news/hap/" class="header">HAP</a>

</div>

<div class="item">

  <a href="/classifieds/" class="header">CLASSIFIEDS</a>

</div>

<div class="item">

  <a href="/contact-us/" class="header">CONTACT</a>

</div>

<div class="item">

  <a href="/e-edition/" class="header">E-EDITION</a>

</div>

<div class="item">

  <div class="header">MORE</div>

    <div class="menu">

      <a class="item" target="_blank" href="http://www.928medialab.com">928 Media Lab</a>

      <a class="item" href="/about/">About Us</a>

      <a class="item" href="/pre-website-archives/">Archives: Pre-Web</a>

      <a class="item" href="/classes/">Classes for the Taking</a>

      <a class="item" href="/clubs/">Clubs &amp; Meetings</a>

      <a class="item" href="/courier-cooks/">Courier Cooks</a>

      <a class="item" href="/users/newsletters-dc/">Newsletter</a>

      <a class="item" href="/events/2019/oct/">Event Calendar</a>

      <a class="item" href="/letter-tips/">Letter Submission Tips</a>

      <a class="item" href="/notices/">Notices</a>

      <a class="item" href="/submit/obituary/">Obituary Submission Guidelines</a>

      <a class="item" href="/other-publications/">Other Publications</a>

      <a class="item" href="/photos/galleries/">Photo Galleries</a>

      <a class="item" href="https://classifiedsplacement.westernnews.com/dcourierui814/WFCategoryClassification.aspx" target="_blank">Place an Ad</a>

      <a class="item" href="/faith-values/">Submit Faith &amp; Values Notice</a>

      <a class="item" href="/classifieds/category/legals/">Public Notices</a>

      <a class="item" href="/purchase-photo/">Purchase a Photo</a>

      <a class="item" target="_blank" href="http://www.homesearchprescott.com">Real Estate Search</a>

      <a class="item" href="https://www.retailmenot.com/everyday">RetailMeNot Everyday</a>

      <a class="item" target="_blank" href="http://www.smartsource.com">Smart Source Coupons</a>

      <a class="item" href="/news/special-sections/">Special Sections</a>

      <a class="item" href="/submit/">Submissions</a>

      <a class="item" href="/subscriber-services/stop-start/">Home Delivery temporary stop</a>

      <a class="item" href="/subscriber-services/index/">Subscribe and Subscriber Services</a>

      <a class="item" target="_blank" href="http://www.circularhub.com/?p=pni#!/flyers/target-circular?flyer_run_id=46644">This Week's Circulars (Flipp)</a>

      <a class="item" href="/tv-listings/">TV Listings</a>

      <a class="item" href="/volunteer/">Volunteer Opportunities</a>

      <a class="item" href="/places/churches/all/">Worship Directory</a>

    </div>

</div>



 



  </div>

  <div class="pusher">

    



    <script>

      dataLayer = [];

      var observer = lozad('.lozad', {

        rootMargin: '500px 0px',

        threshold: 0.1

      });

    </script>

    

  
    

      
          

            <script>

              var category = 'Sports';

              dataLayer.push({

                'contentGroup1': category,

                'dimension1': category

              });

            </script>      

          

      

    

      

    





    

<!-- Google Tag Manager -->

<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-PK5436"

height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':

new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],

j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=

'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);

})(window,document,'script','dataLayer','GTM-PK5436');</script>

<!-- End Google Tag Manager -->

 

    

    

<script>

  window.fbAsyncInit = function() {

    FB.init({

      appId      : '348030695626645',

      xfbml      : true,

      version    : 'v2.9'

    });

    FB.AppEvents.logPageView();

  };

  (function(d, s, id){

     var js, fjs = d.getElementsByTagName(s)[0];

     if (d.getElementById(id)) {return;}

     js = d.createElement(s); js.id = id;

     js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9&appId=348030695626645";

     fjs.parentNode.insertBefore(js, fjs);

   }(document, 'script', 'facebook-jssdk'));

</script>



    

  <div id="main-navigation" class="ui inverted menu no-margin">

  <div class="ui container inverted menu borderless main-nav-items">

    <a href="/" class="item" id="navbar-logo-link">

      <img src="https://westernnews.media.clients.ellingtoncms.com/static-3/custom/dcourier/images/logos/nav-logo.png" alt="dcourier logo" class="ui image small" id="navbar-logo">

    </a>

    <div class="ui simple dropdown item hide-main-nav">

      <a href="/news/news/">NEWS</a>

      <div class="menu">

        <a class="item" href="/news/business/">Business</a>

        <a class="item" href="/news/elections/">Elections</a>

        <a href="/news/hap/" class="item">Happenings &amp; Events</a>

        <a class="item" href="/news/national-international/">National &amp; International</a>

        <a class="item" href="/news/oddnews/">Odd &amp; Interesting</a>
        
        <a class="item" href="/news/chino-valley-review/">CVRnews.com</a>

        <a class="item" href="/news/prescott-valley-tribune/">PVTrib.com</a>

      </div>

    </div>

    <div class="ui simple dropdown item hide-main-nav">

      <a href="/news/opinion/">OPINION</a>

      <div class="menu">

        <a class="item" href="/news/opinion/editorials/">Editorials</a>

        <a class="item" href="/news/opinion/letters/">Letters</a>

        <a class="item" href="/news/opinion/columns/">Columns</a>

        <a class="item" href="/news/opinion/blogs/">Blogs</a>

      </div>

    </div>

    <div class="ui simple dropdown item hide-main-nav">

      <a href="/news/sports/">SPORTS</a>

      <div class="menu">

        <a class="item" href="/news/sports/pro/">Pro</a>

        <a class="item" href="/news/sports/college/">College</a>

        <a class="item" href="/news/sports/preps/">Preps</a>

        <a class="item" href="/news/sports/commentary/">Commentary</a>

      </div>

    </div>

    <div class="ui simple dropdown item hide-main-nav">

      <a href="/news/kudos/">KUDOS</a>

      <div class="menu">

        <a class="item" href="/news/kudos/out-and-about/">Out &amp; About</a>

        <a class="item" href="/news/kudos/chew-on-this/">Chew On This</a>

        <a class="item" href="/news/kudos/music-and-nightlife/">Music &amp; Nightlife</a>

        <a class="item" href="/kudos-calendar/">Nightlife Calendar</a>

        <a class="item" href="/news/kudos/words/">Words</a>

        <a class="item" href="/news/kudos/stage-and-screen/">Stage &amp; Screen</a>

        <a class="item" href="/news/kudos/art-and-style/">Art &amp; Style</a>

      </div>

    </div>

    <div class="ui simple dropdown item hide-main-nav">

      <a href="/news/features/">FEATURES</a>

      <div class="menu">

        <a class="item" href="/courier-cooks/">Courier Cooks</a>

        <a class="item" href="/news/features/neighbors/">Neighbors</a>

        <a class="item" href="/news/features/real-estate/">Real Estate</a>

      </div>

    </div>

    <div class="ui simple dropdown item hide-main-nav">

      <a href="/news/life/">LIFE</a>

      <div class="menu">

        <a class="item" href="/news/life/couples/">Couples</a>

        <a class="item" href="/news/life/births/">Birth</a>

        <a class="item" href="/news/life/recognition/">Recognition</a>

      </div>

    </div>

    <a href="/news/oddnews/" class="item hide-main-nav">ODD</a>

    <a href="/news/obituaries/" class="item hide-main-nav">OBITUARIES</a>

    <a href="/classifieds/" class="item hide-main-nav">CLASSIFIEDS</a>

    <div class="item menu dropdown more-menu hide-main-nav">MORE <i class="dropdown icon"></i></div>

    <div id="nav-search-trigger" class="item menu dropdown">

      <i class="inverted search icon"></i>

    </div>

    <div id="navbar-search" class="ui form">

      <form action="/search/vertical/news.story/" method="get" id="search-form" autocomplete="off">

        <input type="text" name="q" value="" id="nav-search-input" class="nav-search-input" placeholder="Search...">

      </form>

    </div>
    <script>
      var form = document.getElementById('search-form');
      form.addEventListener('submit', function(e) {
        e.preventDefault();
        var input = document.getElementById('nav-search-input');
        var sort = input.value + '&sortby=date';
        window.location = "/search/vertical/news.story/?q=" + sort;
      });
    </script>

    <div class="ui simple dropdown item">

      <a id="sync-login-status" class="log-in" href="https://subscribe.dcourier.com/Wn/Pni/Account/LogOn?ReturnUrl=https://www.dcourier.com/news/2019/oct/06/nfl-roundup-aaron-rodgers-continues-haunt-cowboys-/"></a>

      <a id="sync-login-myaccount" href="https://iservicescirc.westernnews.com/cgi-bin/cmo_cmo.sh/custservice/web/login.html?siteid=PNI"></a>
      <div class="ui inverted menu" id="logoutContainer">
        <div class="item">
          <div id="btnLogout" class="ui negative button">Log Out</div>
        </div>
    </div>

    </div>

    <div id="side-nav-button" class="ui simple dropdown item show-side-nav-button">

      <i class="sidebar icon"></i>

      Menu

    </div>

  </div>

</div>

<script>

  var search = document.getElementById('nav-search-trigger');

  var form =  document.getElementById('navbar-search');

  var input = document.getElementById('nav-search-input');

  search.addEventListener('click', function(e) {

    form.style.zIndex = 1;

    input.classList.toggle('nav-search-animation');

    input.focus();

  });

  input.addEventListener('blur', function(e) {

    this.classList.remove('nav-search-animation');

    form.style.zIndex = -1;

  });

</script> 



    <div id="page" class="ui container">

      



      

<div class="brand-header is-hidden-mobile flex items-center justify-between">

  <div class="brand-main-logo">

    

    <a href="/"><img src="https://westernnews.media.clients.ellingtoncms.com/static-3/custom/dcourier/images/logos/dcourier-logo.png" alt="The Daily Courier Logo"></a>

    

  </div>

  <div class="has-text-centered">
    <a href="https://subscribe.dcourier.com/Wn/Pni/Account/AvailableSubscriptions" class="inline-block right-margin-one-rem hidden" id="subscribe-now">

    <div class="has-text-centered">

      <span class="ui blue header">Subscribe Now</span><br>

    </div>

    </a> 
    
      <a href="/e-edition/"><button class="ui basic primary button e-edition-button">e-Edition</button></a>
    


  </div>

</div>

<div class="toolbar-header is-hidden-mobile flex justify-between items-center">

  <div class="toolbar-item hide-toolbar-item-medium">

    Trusted local news leader for Prescott area communities since 1882

  </div>

  <span class="item-divider hide-toolbar-item-medium"></span>

  <div class="toolbar-item">

    Mon, Oct. 07

  </div>

  <span class="item-divider"></span>

  <div class="toolbar-item">

    

     <a href="/weather/">Weather &nbsp;47.0 <img src="https://westernnews.media.clients.ellingtoncms.com/static-3/ellington_defaults/2.3.0/images/weather/small/sunny.gif" height="15" width="15" alt="weather icon"></a>

    

  </div>

  <span class="item-divider"></span>

  <div class="toolbar-item">

    <a href="/subscriber-services/index/">Subscriber Services</a>

  </div>

  <span class="item-divider"></span>

  <div class="toolbar-item">

    <a href="/contact-us/">Contact Us</a>

  </div>

  <span class="item-divider"></span>

  <div class="toolbar-item">

    <a href="/contact/">News Tips</a>

  </div>

  <span class="item-divider"></span>

  <div class="toolbar-item">

    <a href="https://www.facebook.com/DailyCourier/">  <i class="large facebook icon" aria-hidden="true"></i></a>

  </div>

  <div class="toolbar-item">

    <a href="https://twitter.com/TheDailyCourier"> <i class="large twitter square icon" aria-hidden="true"></i></a>

  </div>

  <div class="toolbar-item">

    <a href="https://www.youtube.com/user/CourierNewsroom/videos"> <i class="large youtube square icon" aria-hidden="true"></i></a>

  </div>
  
  <div class="toolbar-item">

    <a href="https://www.instagram.com/dailycourier/"> <i class="large instagram icon" aria-hidden="true"></i></a>

  </div>

</div>





      

      

      <div class="breadcrumbs">

        

      </div>

      

      <div id="body">

        <div class="wrapper">

          

            

            

            

            

              <div class="content_title">

                


              </div>

            

            

            

            

              

              <div class="page-content">

                

                

                  

                    

                  

                

                



  
    

      
          

            <script>

              var category = 'Sports';

              dataLayer.push({

                'contentGroup1': category,

                'dimension1': category

              });

            </script>      

          

      

    

      

    





<div class="story">

  <div class="ui equal width grid">

    <div class="column story-column ">

      <div class="ui text container">

        <div id="target-story_headline_template">
          

            <h1 class="ui medium header">

            NFL Roundup: Aaron Rodgers continues to haunt Cowboys in 34-24 win



            <div class="sub header">NFL</div>

            </h1>

          


        </div>

        

        

          <div class="story__lead-photo">

            <div class="ui bottom attached segment">

              <div class="photo">

                

                <a href="/photos/2019/oct/06/984991371/"><img src="https://westernnews.media.clients.ellingtoncms.com/img/photos/2019/10/06/nfl_roundup_AP_1_t715.jpg?529764a1de2bdd0f74a9fb4f856b01a9d617b3e9" alt="Dallas Cowboys&#39; Leighton Vander Esch (55) defends as Green Bay Packers&#39; Aaron Rodgers (12) scrambles out of the pocket during the first half of an NFL football game in Arlington, Texas, Sunday, Oct. 6, 2019. (Michael Ainsworth/AP)" class="img-responsive"></a>

                

              </div>

              <div class="lead-photo-info">

                

                <p class="caption">

                  Dallas Cowboys&#39; Leighton Vander Esch (55) defends as Green Bay Packers&#39; Aaron Rodgers (12) scrambles out of the pocket during the first half of an NFL football game in Arlington, Texas, Sunday, Oct. 6, 2019. (Michael Ainsworth/AP)

                </p>

              </div>

            </div>

          </div>

        

        

        <div class="article-info">

          


<div class="has-text-centered">


    


</div>


<div class="has-text-centered article-info__item">


  


    By 


      <a href="/staff/associate-press/">Associated  Press</a>


        


      


    


  


  


    


  


</div>


<div class="has-text-centered article-info__item">


  <div class="article-published">Originally Published: October 6, 2019 10:53 p.m.</div>


  


    <p class="article-published">


      


    </p>


  


</div>


<div class="flex justify-center items-center">


  <div class="sharing-icon fb-share-button" data-href="https://dcourier.com/news/2019/oct/06/nfl-roundup-aaron-rodgers-continues-haunt-cowboys-/" data-layout="button"></div>


  <div class="sharing-icon troublemaker-sharing-icon"><a class="twitter-share-button" href="https://twitter.com/intent/tweet">Tweet</a><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></div>


  <div class="sharing-icon" onclick="window.print()"><i class="print icon print-icon troublemaker-sharing-icon"></i></div>


  <div class="sharing-icon"><a href="mailto:?subject=NFL Roundup: Aaron Rodgers continues to haunt Cowboys in 34-24 win&body=https://dcourier.com/news/2019/oct/06/nfl-roundup-aaron-rodgers-continues-haunt-cowboys-/"><i class="envelope outline icon troublemaker-sharing-icon"></i></a></div>


</div>







        </div>

        <div class="ui divider less-margin"></div>

          <div class="flex justify-center google-ads">

            <!-- /66820660/dc_mb_ict_new -->
<div id='div-gpt-ad-1549650435114-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1549650435114-0'); });
</script>
</div>

          </div>

        

        <div id="overlay">

          <div id="overlay-content">

            <div id='sync-inline-overlay'>

              <div class="story_body" id="target-story_body_template" >

                <p>ARLINGTON, Texas — Aaron Rodgers looked quite comfortable at the home of the Dallas Cowboys — again. Green Bay's star quarterback kept his team moving to a big early lead with more dazzling plays at AT&T Stadium, Aaron Jones scored a career-high four touchdowns and the Packers bounced back from their first loss by hanging on.</p>

<p>Rodgers zipped a sidearm throw to Robert Tonyan to fix one broken play, flipped a left-hander to Tra Carson to rescue another, and helped Green Bay improve to 5-0 inside the retractable-roof stadium where the two-time MVP's first win was the 2011 Super Bowl.</p>

<p>The first three Green Bay wins over the Cowboys at their 10-year-old stadium were all dramatic, highlighted by Rodgers' improbable 35-yard completion to Jared Cook to set up a winning field goal on the final play of a 34-31 divisional-round playoff win three years ago.</p>

<p>Not quite the same drama this time after the Packers (4-1) built a 31-3 lead, although Dak Prescott (463 yards passing) and Amari Cooper (226 yards receiving) set career highs trying to keep things interesting in the fourth quarter.</p>

<p>The last hope for Dallas (3-2) ended with 1:41 left when Brett Maher missed his second field goal — a 33-yarder that would have given the Cowboys a shot at an onside kick down seven.</p>

<p>RAVENS 26, STEELERS 23</p>

<p>PITTSBURGH (AP) — After Pittsburgh quarterback Mason Rudolph was knocked unconscious by a head-high hit in the third quarter Sunday, Justin Tucker made a 46-yard field goal in overtime to lift the Baltimore Ravens past the Steelers 26-23.</p>

<p>Baltimore (3-2) snapped a two-game skid when safety Marlon Humphrey stripped Steelers wide receiver JuJu Smith-Schuster and recovered the fumble at the Pittsburgh 34. Tucker knocked through the winner four plays later. He also forced overtime with a field goal 14 seconds from the end of regulation.</p>

<p>Lamar Jackson threw for 161 yards with a touchdown and three interceptions and also ran for a game-high 70 yards. Mark Ingram ran for a touchdown for the Ravens, who won in Pittsburgh (1-4) for the second straight season.</p>

<p>Rudolph threw for 131 yards and a score before suffering a concussion following a hit to the chin by Baltimore safety Earl Thomas. Backup Devlin Hodges played admirably in Rudolph's place, throwing for 68 yards and directing a pair of scoring drives after Rudolph's exit. James Conner ran for 55 yards and a touchdown for Pittsburgh.</p>

<p>COLTS 19, CHIEFS 13</p>

<p>KANSAS CITY, Mo. (AP) — The Indianapolis Colts accomplished Sunday night what they failed to do in January. They won in Kansas City.</p>

<p>Marlon Mack ran for 132 yards, ageless kicker Adam Vinatieri knocked through four field goals and the Colts atoned ever-so-slightly for that playoff defeat by shutting down Patrick Mahomes and the Chiefs' vaunted offense in a 19-13 victory at Arrowhead Stadium.</p>

<p>The Colts (3-2) allowed points on the Chiefs' first two possessions before shutting them out until Harrison Butker's field goal with 1:16 to go. Indianapolis recovered the onside kick to seal the win.</p>

<p>Mahomes threw for 321 yards and a touchdown, and the Chiefs (4-1) had just 36 yards rushing despite getting top running back Damien Williams back from an injury, all while watching their record streak of 22 straight games scoring at least 26 points come to a crashing conclusion.</p>

<p>BRONCOS 20, CHARGERS 13</p>

<p>CARSON, Calif. (AP) — Phillip Lindsay ran for 114 yards and Denver's defense forced three turnovers as the Broncos got their first win under Vic Fangio.</p>

<p>Joe Flacco completed 14 of 20 passes for 162 yards and a touchdown as Denver (1-4) raced to a 17-0 lead in the second quarter and held on for the 500th victory in franchise history.</p>

<p>Los Angeles (2-3) struggled most of the day and had two turnovers inside the Denver 5. The Chargers got within 17-10 midway through the fourth quarter, but Denver's Brandon McManus put it out of reach with a 46-yard field goal with 1:55 remaining.</p>

<p>Chase McLaughlin's 32-yard field goal brought LA back within a touchdown with 15 seconds remaining, but Denver (1-4) recovered the onside kick to put it away.</p>

<p>Philip Rivers was 32 of 48 for 211 yards with two interceptions. Melvin Gordon was held to 31 yards rushing in his first game back after a holdout. Fellow running back Austin Ekeler had 15 receptions for 86 yards.</p>

<p>RAIDERS 24, BEARS 21</p>

<p>LONDON (AP) — Josh Jacobs scored his second touchdown of the game with a leap from the 2-yard line with 1:57 to play, capping a 97-yard drive that helped the Raiders rally after blowing a 17-point lead.</p>

<p>The touchdown was part of a roller-coaster game that delighted the sellout crowd in London. The Raiders (3-2) broke out to a 17-0 halftime lead only to fall behind the Bears (3-2) in a mistake-filled third quarter.</p>

<p>Then Oakland fumbled at the goal line when going in for the go-ahead score, needed a replay review to overturn a fumble on a successful fake punt on the winning drive, then intercepted Chicago backup Chase Daniel with 1:14 to go to seal the victory.</p>

<p>It sure didn't come easy, but made Oakland's weeklong stay in London a successful one, ended by a satisfying victory in the Raiders' first game against the Bears since dealing star edge rusher Khalil Mack to Chicago before last season.</p>

<p>That trade has come under heavy scrutiny as Mack led the Bears to the playoffs last year while the Raiders struggled. But Oakland came out ahead this day, with Mack's only big play coming when he recovered a botched pitch by Derek Carr that sparked Chicago's third-quarter comeback.</p>

<p>The Bears turned that turnover into a 1-yard run by David Montgomery and got two TD passes from Daniel to Allen Robinson in the third quarter to take a 21-17 lead.</p>

<p>SAINTS 31, BUCCANEERS 24</p>

<p>NEW ORLEANS (AP) — Teddy Bridgewater passed for 314 yards and four touchdowns to remain unbeaten in three starts for the Saints this season.</p>

<p>With Bridgewater getting increasingly accustomed to playing for the injured Drew Brees, he had his best game yet for New Orleans (4-1) against a Tampa Bay defense that entered the game ranked second to last in the NFL against the pass.</p>

<p>With inspiring chants of "Ted-dy! Ted-dy!" from the Superdome crowd, Bridgewater completed 26 of 34 passes, with his two touchdown throws to Michael Thomas and one each to Jared Cook and Ted Ginn Jr.</p>

<p>Tampa Bay's secondary struggled to stay with Thomas, who finished with 11 catches for 182 yards.</p>

<p>Bridgewater, who began playing in Week 2 after Brees' first-quarter thumb injury in a loss to the Rams, had not completed a pass as long as 30 yards in his first 11 quarters of play this season.</p>

<p>That changed in the first quarter against the Bucs (2-3) with a 34-yard completion to Thomas. Bridgewater later hit Thomas for a 42-yarder early in the second half, setting up his 33-yard scoring strike to Ginn.</p>

<p>Bucs QB Jameis Winston saw his production drop dramatically from his triumphant 385-yard, four-TD performance against the Rams in Week 4. He was 15 of 27 for 204 yards and two touchdowns to Chris Godwin. But Winston could not connect with receiver Mike Evans, who was Winston's intended target just three times and did not have a catch.</p>

<p>PATRIOTS 33, REDSKINS 7</p>

<p>LANDOVER, Md. (AP) — Tom Brady picked apart the lowly Redskins, helped the Patriots stay unbeaten and climbed past a former NFL star in the record book.</p>

<p>Brady threw for 348 yards and three touchdowns, and the Patriots got another strong performance from their defense.</p>

<p>Now in his 20th season, Brady whisked by Brett Favre into third place on the career list with 71,923 yards passing. The 42-year-old Brady now trails only Peyton Manning (71,940 yards) and Drew Brees (74,845).</p>

<p>Brady also edged closer to Manning's record 539 touchdown passes, connecting with Julian Edelman, Brandon Bolden and Ryan Izzo to bring his total to 527. Shrugging off four sacks, Brady completed 28 of 42 passes — including a 15-yarder to Edelman in the third quarter to eclipse Favre.</p>

<p>This is the fifth time in franchise history that New England has started the season 5-0, and only the second time since 2007.</p>

<p>Playing for the first time since breaking his leg against Philadelphia last December, Redskins quarterback Colt McCoy went 18 for 27 for 119 yards and an interception. McCoy began the season behind Case Keenum and rookie Dwayne Haskins Jr., but got the start over the injured Keenum and inexperienced Haskins for the Redskins (0-5).</p>

<p>McCoy was sacked six times, marking the first time in franchise history New England has four straight games with at least five sacks. In addition, the Patriots completed a fifth consecutive game without allowing a touchdown pass, the first team to pull off that feat since the 1988 Cleveland Browns.</p>

<p>The defeat kept the pressure on Redskins coach Jay Gruden, whose job status appears to be tenuous in the wake of his team's 0-5 start. Gruden is 35-49-1 over five-plus seasons with Washington.</p>

<p>PANTHERS 34, JAGUARS 27</p>

<p>CHARLOTTE, N.C. (AP) — Christian McCaffrey tied a career high with 237 yards from scrimmage and scored three touchdowns, Brian Burns returned a fumble 56 yards for a touchdown and had a strip-sack in the fourth quarter.</p>

<p>McCaffrey set a franchise record with an 84-yard TD run and scored on a 5-yard run when he somersaulted into the end zone. He also caught an 18-yard TD pass from Kyle Allen before leaving with five minutes remaining after cramping.</p>

<p>But McCaffrey's seldom-used replacement Reggie Bonnafon had a 59-yard touchdown run to put Carolina (3-2) up by seven with 3:34 left.</p>

<p>Carolina's defense thwarted Jacksonville's final two scoring drives when Burns sacked rookie Gardner Minshew to force a turnover and Luke Kuechly batted down a pass on the game's final play.</p>

<p>Minshew finished 26 of 45 for 374 yards with two touchdowns and one interception for the Jaguars (2-3). Leonard Fournette had 23 carries for 108 yards and a score.</p>

<p>BLLS 14, TITANS 7</p>

<p>NASHVILLE, Tenn. (AP) — Josh Allen threw for 219 yards and two touchdowns as Buffalo won a defensive showdown for its third straight win in this series.</p>

<p>The Bills (4-1) now have won three consecutive games away from Buffalo for the first time since 2004, though so many Buffalo fans traveled here it felt much more like a home game. It's also the first time they've started a season perfect through three road games since 1993.</p>

<p>This game featured two of the NFL's stingiest defenses, with the Titans fourth giving up 15.5 points, and the Bills fifth, allowing 15.8 points a game. Jordan Phillips had a career-high three sacks — by halftime — as Buffalo sacked Marcus Mariota five times even with three-time Pro Bowl left tackle Taylor Lewan back from his four-game suspension for performance enhancers.</p>

<p>The Titans (2-3) sacked Allen four times only to lose their third in four games on a day replacement kicker Cairo Santos missed three field goals and had a fourth blocked.</p>

<p>TEXANS 53, FALCONS 32</p>

<p>HOUSTON (AP) — Deshaun Watson threw for a career-high 426 yards and tied his personal best with five touchdown passes, including three to Will Fuller.</p>

<p>A week after scoring a season-low 10 points in a loss to Carolina, Watson and Houston's offense bounced back on a day he was 28 of 33 and became the first player to top 400 yards passing against the Falcons since Week 16 of 2012.</p>

<p>Fuller had a career-best 217 yards receiving, Darren Fells had two touchdown grabs for the Texans (3-2) and Carlos Hyde added a rushing TD.</p>

<p>Houston's beleaguered offensive line didn't allow a sack on Sunday after giving up 18 through the first four games.</p>

<p>Matt Ryan had 330 yards passing with three touchdowns and one interception for the Falcons (1-4), who lost their third straight game.</p>

<p>It was Watson's first meeting with the Falcons after the Georgia native worked as a ball boy for the team all four years of high school. Watson shared a moment with Falcons owner Arthur Blank on the field before the game. Blank started the program at the Boys & Girls Clubs of Hall County that allowed Watson the opportunity to work for the Falcons as a teenager.</p>

<p>EAGLES 31, JETS 6</p>

<p>PHILADELPHIA (AP) — Nate Gerry returned an interception for a score and Orlando Scandrick took a strip-sack the distance.</p>

<p>The Eagles (3-2) smothered third-string quarterback Luke Falk and overwhelmed New York's offense on a day Carson Wentz was ordinary. Wentz threw for 189 yards and one touchdown. Jordan Howard ran for 62 yards and one TD.</p>

<p>Sam Darnold missed his third straight game for the Jets (0-4) while he recovers from mononucleosis, so Falk made his second start after opening the season on New York's practice squad. Falk threw two interceptions and was sacked nine times before leaving late in the game and being replaced by David Fales, who was re-signed by the Jets on Friday. Falk replaced Trevor Siemian — Darnold's original backup — after he sustained a season-ending ankle injury in Week 2.</p>

<p>Gerry gave the Eagles a 14-0 lead in the first quarter when he jumped in front of Falk's fourth-down pass and returned it 51 yards.</p>

<p>Scandrick, playing his first game with the Eagles, had two sacks on corner blitzes. He stole the ball from Falk on the second one and ran it back 44 yards to make it 31-6 in the fourth quarter.</p>

<p>Brandon Graham had a career-high three of Philadelphia's 10 sacks after he only had four last season.</p>

<p>VIKINGS 28, GIANTS 10</p>

<p>EAST RUTHERFORD, N.J. (AP) — Kirk Cousins threw two touchdown passes to Adam Thielen, Dalvin Cook ran for 132 yards and the Vikings made life miserable for Daniel Jones.</p>

<p>The win came just a week after the Vikings (3-2) did little in a 16-6 loss to the Chicago Bears and Thielen insisted the team had to stop being one dimensional on offense, relying solely on the run.</p>

<p>And that's exactly what Minnesota did. It hit the Giants (2-3) with a bit of everything — pass, run and the defense — in ending the two-game winning streak Jones engineered since replacing Eli Manning at quarterback. The Vikings gained 490 yards on offense.</p>

<p>The defense limited New York to 211 yards, sacked Jones four times and hit him countless other times. That defense also chipped in with a safety when linebacker Anthony Barr tackled Jon Hilliman in the end zone after New York recovered Cook's fumble at the 1.</p>

<p>Cousins completed 22 of 27 for a season-high 306 yards and had touchdown passes of 15 and 9 yards to Thielen. The receiver, who complained after a two-catch, 6-yard game against Chicago, finished with seven catches for 130 yards.</p>

                

                

              </div> 

            </div>

          </div> 

        </div> 

        

        









<div class="ui compact fluid five item menu story-tools">

  

  <a href="/contact/" class="item">Contact</a>

    

  <a href="/mailfriend/155/848902/f805fca0aa/" rel="popup(620x650)" class="item"><i class="large envelope outline icon"></i></a>

  <a href="https://www.facebook.com/sharer.php?u=http://www.dcourier.com/news/2019/oct/06/nfl-roundup-aaron-rodgers-continues-haunt-cowboys-/" target="new" class="item"><i class="large facebook icon"></i></a>

  <a href="http://twitter.com/home?status=http://www.dcourier.com/news/2019/oct/06/nfl-roundup-aaron-rodgers-continues-haunt-cowboys-/" class="item"><i class="large twitter icon"></i></a>

  <a href="javascript:void(0)" class="item print-icon" onclick="window.print()"><i class="large print icon"></i></a>      

  

</div>





        <div class="fluid ui grey button top-margin-one-rem newsletter">Sign up for Courier e-News Alerts</div>

        <div class="ui grey segment most-read">

<div class="ui header">Most Read</div>

	<div class="ui top attached tabular menu">

		<div class="item active" data-tab="sevendays">7 days</div>

		<div class="item" data-tab="thirtydays">30 days</div>

	</div>

	<div class="ui bottom attached tab segment active" data-tab="sevendays">
	    <ul id="tab-content1"class="ui relaxed list">
		<li class="item"><a href="/news/2019/oct/06/why-are-flags-half-staff-today-oct-6-2019/">Why are flags at half-staff today, Oct. 6, 2019? </a></li>
		<li class="item"><a href="/news/2019/sep/30/newlyweds-among-4-arrested-assaulting-prescott-pol/">Newlyweds among 4 arrested for assaulting Prescott police officers </a></li>
		<li class="item"><a href="/news/2019/oct/01/name-man-killed-hwy-89-fatal-crash-sept-27-release/">Name of man killed in Hwy. 89 fatal crash Sept. 27 released </a></li>
		<li class="item"><a href="/news/2019/sep/30/motorcyclist-critical-condition-crash-hwy-89a/">Motorcyclist crashes, dies on Highway 89A </a></li>
		<li class="item"><a href="/news/2019/sep/27/southbound-hwy-89-closed-due-fatal-crash/">1 dead after truck driven off overpass </a></li>
		<li class="item"><a href="/news/2019/sep/28/obituary-pat-mccarty/">Obituary: Pat McCarty </a></li>
		<li class="item"><a href="/news/2019/oct/01/2-killed-iron-springs-road-sept-24-identified/">2 killed on Iron Springs Road Sept. 24 identified </a></li>
		<li class="item"><a href="/news/2019/oct/03/2019-wings-out-west-air-show-oct-5/">2019 Wings Out West Air Show, Oct. 5 </a></li>
		<li class="item"><a href="/news/2019/oct/05/need2know-former-native-grill-wings-sold-new-owner/">Need2Know: Former Native Grill & Wings sold to new owners in Prescott Valley; Whiskey Row Pub rebranded ‘1881 Spirits’ </a></li>
		<li class="item"><a href="/news/2019/oct/05/air-show-pilot-set-more-grounded-life/">Air show pilot set for a more grounded life </a></li>
</ul>
    	</div>
    	<div class="ui bottom attached tab segment" data-tab="thirtydays">
	    <ul id="tab-content2"class="ui relaxed list">
		<li class="item"><a href="/news/2019/oct/06/why-are-flags-half-staff-today-oct-6-2019/">Why are flags at half-staff today, Oct. 6, 2019? </a></li>
		<li class="item"><a href="/news/2019/sep/27/southbound-hwy-89-closed-due-fatal-crash/">Southbound Hwy 89 closed due to fatal crash </a></li>
		<li class="item"><a href="/news/2019/sep/27/southbound-hwy-89-closed-due-fatal-crash/">1 dead after truck driven off overpass </a></li>
		<li class="item"><a href="/news/2019/sep/10/wyatt-earp-behind-scenes-tale/">Wyatt Earp: A behind-the-scenes tale </a></li>
		<li class="item"><a href="/news/2019/sep/30/newlyweds-among-4-arrested-assaulting-prescott-pol/">Newlyweds among 4 arrested for assaulting Prescott police officers </a></li>
		<li class="item"><a href="/news/2019/sep/25/2-killed-collision-iron-springs-road/">2 killed in collision on Iron Springs Road </a></li>
		<li class="item"><a href="/news/2019/sep/22/fire-erupts-near-walker-evacuation-ordered-lookout/">Fire erupts near Walker; evacuations ordered for Lookout, Maverick areas </a></li>
		<li class="item"><a href="/news/2019/sep/19/local-drug-dealers-arrested-chino-valley/">Local drug dealers arrested in Chino Valley </a></li>
		<li class="item"><a href="/news/2019/sep/17/major-crash-completely-closes-highway-169-road-now/">Major crash completely closes Highway 169; road now open </a></li>
		<li class="item"><a href="/news/2019/sep/22/burning-operations-completed-surprise-fire-near-gr/">Fire update: Evacuation ordered in Lookout Mountain, Maverick area, Sheriff's Office reports </a></li>
</ul>
    	</div>

</div>



        

        

        

        <div class="ui segment has-text-centered more-like-this"> 

          <h3>More like this story</h3>        

          

            <div class="item"><a href="/news/2016/nov/06/falk-leads-no-25-washington-state-past-arizona-69-/" class="blue-link">Falk leads No. 25 Washington State past Arizona, 69-7</a></div>

          

            <div class="item"><a href="/news/2019/oct/05/top-25-roundup-no-10-florida-beats-no-7-auburn-24-/" class="blue-link">Top 25 Roundup: No. 10 Florida beats No. 7 Auburn 24-13 at Swamp</a></div>

          

            <div class="item"><a href="/news/2018/sep/23/roundup-allen-bills-16-1-2-point-underdogs-stun-vi/" class="blue-link">Roundup: Allen, Bills, 16 1-2 point underdogs, stun Vikings 27-6</a></div>

          

            <div class="item"><a href="/news/2019/sep/28/top-25-roundup-fighting-irish-overcome-halftime-de/" class="blue-link">Top 25 Roundup: Fighting Irish overcome halftime deficit to defeat No. 18 Virginia 35-20</a></div>

          

            <div class="item"><a href="/news/2016/nov/06/mississippi-state-upsets-no-7-texas-m/" class="blue-link">Mississippi State upsets No. 7 Texas A&amp;M</a></div>

          

        </div>

        

        

        

        

        <div class="ui segment has-text-centered submit-feedback">

          <h3>SUBMIT FEEDBACK</h3>

            <p>Click Below to:</p>

            <p>

              <div><a href="/submit/rants-and-raves/" class="blue-link">File a Rant or Rave about this story</a></div>

              <div><a href="/contact/" class="blue-link">Ask us a question</a></div>

              <div><a href="/submit/letter-to-the-editor/" class="blue-link">Submit a letter to the editor</a></div>

              <div><a href="/contact/" class="blue-link">Send us a news tip or story idea</a></div>

            </p>

        </div>

      </div>

    </div>

    

    <div class="six wide column is-hidden-touch">

      <div class="right-rail">

  <div class="flex justify-center google-ads">

    <!-- /66820660/dc_rr_1 -->
<div id='div-gpt-ad-1549645330807-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1549645330807-0'); });
</script>
</div>




  </div>

  <div class="flex justify-center google-ads">

    <!-- /66820660/dc_rr_2 -->
<div id='div-gpt-ad-1549646914054-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1549646914054-0'); });
</script>
</div>



  </div>

  <div class="flex justify-center google-ads">

    <!-- /66820660/dc_rr_3 -->
<div id='div-gpt-ad-1549647070425-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1549647070425-0'); });
</script>
</div>



  </div>





  

    

  

<div class="calendar-tease">

  <div class="ui segment">
    <div class="ui header">Event Calendar</div>
    <a href="/events/2019/oct"><img src="https://westernnews.media.clients.ellingtoncms.com/static-3/custom/images/calendar3.jpg" class="img-responsive" alt="Event Calendar link"></a>
    <a href="/submit-event/">

      <div class="positive ui button"><i class="plus icon"></i> Submit Event</div>

    </a>

  </div>

  

</div>


  



  

    <div id="circularhub_module_2880" style="display:none;"></div>

<script src="//api.circularhub.com/2880/3d0d63dcd65ca89a/flyertown_module.js" async></script>

<div id="flipp-overlay" class="ui segment">

  <h3>This Week's Circulars</h3>

  <div id="flipp-overlay-content">

    <p>To view money-saving ads...</p>

    <form method="get" action="subscribe.dcourier.com/wn/pni/account/availableSubscriptions?returnUrl=https://www.dcourier.com/news/2019/oct/06/nfl-roundup-aaron-rodgers-continues-haunt-cowboys-/">

    <button type="submit" class="ui positive button">Subscribe Now</button>

    </form>

  </div>

</div>

  

</div>

    </div>

  </div>

</div>

<div class="ui modal">
  <div class="content">
        <!-- Begin Mailchimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/classic-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://westernnews.us12.list-manage.com/subscribe/post?u=ad9bbcca1da2e5673f9a3e417&amp;id=08f7bd4bc7" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
    <div id="mc_embed_signup_scroll">
	<h2>Subscribe to our mailing list</h2>
<div class="indicates-required"><span class="asterisk">*</span> indicates required</div>
<div class="mc-field-group">
	<label for="mce-EMAIL">Email Address  <span class="asterisk">*</span>
</label>
	<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL">
</div>
<h3>Please select which news alerts you would like to receive</h3>
<div class="mc-field-group input-group">
    <strong>Latest News </strong>
    <ul><li><input type="checkbox" value="1" name="group[6261][1]" id="mce-group[6261]-6261-0"><label for="mce-group[6261]-6261-0"> Latest News</label></li>
</ul>
</div>
<div class="mc-field-group input-group">
    <strong>PVTrib </strong>
    <ul><li><input type="checkbox" value="2" name="group[7605][2]" id="mce-group[7605]-7605-0"><label for="mce-group[7605]-7605-0"> Prescott Valley Tribune</label></li>
</ul>
</div>
<div class="mc-field-group input-group">
    <strong>CVRNews </strong>
    <ul><li><input type="checkbox" value="4" name="group[7609][4]" id="mce-group[7609]-7609-0"><label for="mce-group[7609]-7609-0"> Chino Valley Review</label></li>
</ul>
</div>
<div class="mc-field-group input-group">
    <strong>Sports </strong>
    <ul><li><input type="checkbox" value="8" name="group[13665]" id="mce-group[13665]-13665-0"><label for="mce-group[13665]-13665-0"> Latest Sports News</label></li>
</ul>
</div>
<div class="mc-field-group input-group">
    <strong>Odd &amp; Interesting </strong>
    <ul><li><input type="checkbox" value="16" name="group[13669]" id="mce-group[13669]-13669-0"><label for="mce-group[13669]-13669-0"> Latest Odd &amp; Interesting News</label></li>
</ul>
</div>
<div class="mc-field-group input-group">
    <strong>Obituaries </strong>
    <ul><li><input type="checkbox" value="32" name="group[13673]" id="mce-group[13673]-13673-0"><label for="mce-group[13673]-13673-0"> Obituary Newsletter</label></li>
</ul>
</div>
	<div id="mce-responses" class="clear">
		<div class="response" id="mce-error-response" style="display:none"></div>
		<div class="response" id="mce-success-response" style="display:none"></div>
	</div>    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_ad9bbcca1da2e5673f9a3e417_08f7bd4bc7" tabindex="-1" value=""></div>
    <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
    </div>
</form>
</div>

<!--End mc_embed_signup-->
  </div>
</div>




<script>

	$('.menu .item')

		.tab();

  $('.ui.modal').modal('attach events', '.newsletter.button', 'show')

</script>





                

                  

                    

                  

                

              </div>

            

            

            

          

        </div> 

      

<div class="flex justify-center">

  <!-- /66820660/dc_footer_lb -->
<div id='div-gpt-ad-1549647228842-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1549647228842-0'); });
</script>
</div>



</div>

<div class="flex justify-center bottom-mobile-leaderboard">

  <!-- /66820660/dc_mobile_footer -->

<div id='div-gpt-ad-1550166102071-0'>

<script>

googletag.cmd.push(function() { googletag.display('div-gpt-ad-1550166102071-0'); });

</script>

</div>

</div>

<div class="flex justify-center">

  <!-- /66820660/dc_mb_footer -->
<div id='div-gpt-ad-1549650210581-0' >
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1549650210581-0'); });
</script>
</div>

</div>



      </div> 

      

      

    

    </div> 



      



    

    

  </div>  

    

  <div id="main-footer" class="footer ui centered grid">

  <div class="footer__columns six column doubling row">

    <div class="footer__search three wide column has-text-centered">

      <div class="ui form">

        <form action="/search/" method="get" class="ui icon input" autocomplete="off">

          <input type="text" name="q" value="">

          <i class="search icon"></i>

        </form>

      </div>

      <div class="footer__logo">

        

          <img src="https://westernnews.media.clients.ellingtoncms.com/static-3/custom/dcourier/images/logos/footer-logo.gif" alt="footer logo" class="ui fluid image"/>

        

      </div>

    </div>

    <div class="column">

      <div class="ui list">

        <div class="item">

          <div class="header">SECTIONS</div>

          <div class="ui divider"></div>

        </div>

        <div class="item"><a href="/news/news/">News</a></div>

        <div class="item"><a href="/news/opinion/">Opinion</a></div>

        <div class="item"><a href="/news/sports/">Sports</a></div>

        <div class="item"><a href="/news/kudos/">Kudos</a></div>

        <div class="item"><a href="/news/features/">Features</a></div>

        <div class="item"><a href="/news/life/">Life</a></div>

        <div class="item"><a href="/news/obituaries/">Obituaries</a></div>

      </div>

    </div>

    <div class="column">

      <div class="ui list">

        <div class="item">

          <div class="header">CLASSIFIEDS</div>

          <div class="ui divider"></div>

        </div>

        <div class="item"><a href="/classifieds/">Main</a></div>

        <div class="item"><a href="/classifieds/category/local-employment/">Jobs</a></div>

        <div class="item"><a href="/classifieds/category/autos-and-vehicles/">Cars</a></div>

        <div class="item"><a href="/classifieds/category/real-estate/">Real Estate</a></div>

        <div class="item"><a  href="https://classifiedsplacement.westernnews.com/dcourierui814/WFCategoryClassification.aspx" target="_blank">Place an Ad</a></div>

        <div class="item"><a href="/about/">About Us</a></div>

        <div class="item"><a href="/contact/">Contact Us</a></div>

      </div>

    </div>

    <div class="column">

      <div class="ui list">

        <div class="item">

          <div class="header">EVENTS</div>

          <div class="ui divider"></div>

        </div>

        <div class="item"><a href="/events/">Today's Events</a></div>

        <div class="item"><a href="/events/search/">Search Events</a></div>

        <div class="item"><a href="/submit-event/">Submit Event</a></div>

      </div>

    </div>

    <div class="column">

      <div class="ui list">

        <div class="item">

          <div class="header">SUBMISSIONS</div>

          <div class="ui divider"></div>

        </div>

        <div class="item"><a href="/contact/">Submit a News Tip</a></div>

        <div class="item"><a href="/submit/birth-announcement/">Birth</a></div>

        <div class="item"><a href="/submit/engagement-wedding-announcement/">Wedding <br> Engagement</a></div>

        <div class="item"><a href="/submit/anniversary/">Anniversary</a></div>

        <div class="item"><a href="/contact/">Website Feedback</a></div>

        <div class="item"><a href="/subscriber-services/index/">Subscriber Services</a></div>

      </div>

    </div>


  </div>

  <div class="one column row">

    <div class='copyright'>

      

        <p class="has-text-white"><span>Contents of this site are &copy; Copyright 2019 The Daily Courier and Western News&amp;Info&reg;, Inc. All rights reserved. | </span><a href="/terms-of-service/" class="has-text-white"> Terms of Service</a> | <a href="/privacy-policy/" class="has-text-white">Privacy Policy</a></p>

      

    </div>

  </div>

</div>



  

<script>

	$('.menu .item')

		.tab();

  $('.ui.modal').modal('attach events', '.newsletter.button', 'show')

</script>

    

  <script src="https://cdn.syncronex.com/libs/v1.8/syncLoginSdk.js"></script>

  <script>

    function setView (status) {
      var login = document.getElementById('sync-login-status');
      var myaccount = document.getElementById('sync-login-myaccount');
      var logout = document.getElementById('btnLogout');
      var logoutContainer = document.getElementById('logoutContainer');
      var subscribeNow = document.getElementById('subscribe-now');

      if (status === 'loggedIn') {
        myaccount.textContent = ' My Account';
        myaccount.href = "https://iservicescirc.westernnews.com/cgi-bin/cmo_cmo.sh/custservice/web/login.html?siteid=PNI";
        login.style.display = 'none';
      } else if (status === "notLoggedIn") {
        subscribeNow.style.display = 'inline-block';
        myaccount.style.display = 'none';
        logoutContainer.style.display = 'none';
        login.href = "https://subscribe.dcourier.com/Wn/Pni/Account/LogOn?ReturnUrl=https://www.dcourier.com/news/2019/oct/06/nfl-roundup-aaron-rodgers-continues-haunt-cowboys-/";
        login.textContent = ' Log In';
      }
    }

    var sdk = window.syncLoginSdk;

    sdk.applicationOrigin = 'https://subscribe.dcourier.com';

    sdk.debug = true;

    sdk.apiTimeout = 5000;

    sdk.sessionExpireDays = 30;

    sdk.requireLegacyLogin = true;

    sdk.tenantId = 'wn-pni';

    // getLoginStatus takes two parameters - the first is a success callback, the second is a failure callback

    sdk.getLoginStatus(function(data) {
      window.loggedIn=true;
      setView("loggedIn");

    }, function(errStatus) {
      window.loggedIn=false;
      setView("notLoggedIn");

    })

    var btnLogout = document.getElementById('btnLogout');
    btnLogout.addEventListener('click', function(e) {
      sdk.logOut(function() {
        window.location.reload();
      }, function() {
        alert('Log out failed.');
      });
    })

  </script>


  <script>

    $('.ui.sidebar-nav')

    .sidebar('attach events', '.show-side-nav-button');

    $('.top-more-menu')

    .sidebar({

      transition: 'push',

    })

    .sidebar('attach events', 'div.more-menu');

  </script>

  <script type="text/javascript" src="https://westernnews.media.clients.ellingtoncms.com/static-3/javascript/linkify.min.js?v=7"></script>  



  <script type="text/javascript" src="https://westernnews.media.clients.ellingtoncms.com/static-3/javascript/linkify-jquery.min.js?v=8"></script>



  <script>



     // turn plain text links into hyperlinks



    $('p').linkify();



    $('#sidebar').linkify({



      target: "_blank"



    });



  </script>

  <script type="text/javascript" src="https://westernnews.media.clients.ellingtoncms.com/static-3/javascript/word_limit.js?v=7" async></script>

  <script type="text/javascript" src="https://westernnews.media.clients.ellingtoncms.com/static-3/javascript/westernnews.js?v=18" async></script>



</body>

</html>

